aboutsummaryrefslogtreecommitdiff
path: root/lib/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/shell.nix')
-rw-r--r--lib/shell.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/shell.nix b/lib/shell.nix
index 3f6defc..d7d15fa 100644
--- a/lib/shell.nix
+++ b/lib/shell.nix
@@ -16,6 +16,9 @@ let
16 }; 16 };
17 17
18in rec { 18in rec {
19 ifSomeAttrs = attrs: f: pkgs.lib.optionalString (attrs != {}) (f attrs);
20 ifSomeList = list: f: pkgs.lib.optionalString (list != []) (f list);
21
19 exportEnvVar = k: v: '' 22 exportEnvVar = k: v: ''
20 export ${escapeShellArg k}="${v}" 23 export ${escapeShellArg k}="${v}"
21 ''; 24 '';