diff options
author | pacien | 2022-10-30 01:05:45 +0200 |
---|---|---|
committer | pacien | 2022-10-30 01:10:54 +0200 |
commit | 0fddc74a3f9add47841124b4d77b097f4646d14f (patch) | |
tree | e0e841d9cfc101a1247e9526f7cf65d50d4ed4c2 /flake.nix | |
parent | f864eeca506331c1dee2cd3f5f0df4fe806f303a (diff) | |
download | ldgallery-0fddc74a3f9add47841124b4d77b097f4646d14f.tar.gz |
compiler: fix support for non-utf8 terminals
The compiler echoes the names of the files being processed.
Those file names may contain UTF-8 characters.
However, some consoles may not support those.
This is notably the case of the Windows CMD or on Linux with the legacy
C locale. This caused the following error:
ldgallery: <stdout>: commitBuffer: invalid argument (invalid character)
This patch adds automatic transliteration when a non-UTF8 terminal is
detected, so that neither the compiler or the terminal crash due to UTF8
characters.
GitHub: closes #341
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 2 |
1 files changed, 0 insertions, 2 deletions
@@ -123,8 +123,6 @@ | |||
123 | src = ./example; | 123 | src = ./example; |
124 | nativeBuildInputs = [ ldgallery ]; | 124 | nativeBuildInputs = [ ldgallery ]; |
125 | buildPhase = '' | 125 | buildPhase = '' |
126 | # Need UTF-8: https://github.com/ldgallery/ldgallery/issues/341 | ||
127 | export LC_ALL=C.UTF-8 | ||
128 | ldgallery --input-dir src --output-dir $out --with-viewer | 126 | ldgallery --input-dir src --output-dir $out --with-viewer |
129 | ''; | 127 | ''; |
130 | installPhase = ":"; | 128 | installPhase = ":"; |