aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix18
1 files changed, 7 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index bbfd8f0..2118e42 100644
--- a/flake.nix
+++ b/flake.nix
@@ -39,18 +39,14 @@
39 version = "SNAPSHOT"; 39 version = "SNAPSHOT";
40 src = ./.; 40 src = ./.;
41 buildInputs = [ pkgs.nim ]; 41 buildInputs = [ pkgs.nim ];
42 buildPhase = ''
43 export VERSION=${final.version}
44 nim c --nimcache:. -d:release main.nim
45 '';
46 doCheck = true; 42 doCheck = true;
47 checkPhase = '' 43 makeFlags = [
48 nim r --nimcache:. -d:test main.nim 44 "NIM_FLAGS=--nimcache:."
49 ''; 45 "VERSION=${final.version}"
50 installPhase = '' 46 ];
51 mkdir -p $out/bin 47 installFlags = [
52 mv main $out/bin/${final.meta.mainProgram} 48 "DESTDIR=$(out)"
53 ''; 49 ];
54 }); 50 });
55 }); 51 });
56} 52}