diff options
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r-- | app/CMakeLists.txt | 9 |
1 files changed, 4 insertions, 5 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt index 073f7d7..6449aeb 100644 --- a/app/CMakeLists.txt +++ b/app/CMakeLists.txt | |||
@@ -54,9 +54,8 @@ ExternalProject_Add(libressl | |||
54 | 54 | ||
55 | ExternalProject_Add(tinc | 55 | ExternalProject_Add(tinc |
56 | DEPENDS lzo libressl | 56 | DEPENDS lzo libressl |
57 | URL https://github.com/gsliepen/tinc/archive/017a7fb57655d9b1d706ee78f7e3d0000411b883.tar.gz | 57 | URL https://github.com/gsliepen/tinc/archive/6682a0d29cbb70b216a3fe02f2812963dee607d0.tar.gz |
58 | URL_HASH SHA256=27f361706d09f81fbbef7021f37adf5375f01857b23272a490df066ca290a530 | 58 | URL_HASH SHA256=ffb0e6c02b0112c095366b3baa89f5ed56cc5f644be40268696ce7741e76452a |
59 | PATCH_COMMAND sed -i -e "s/test(void)/test(void *x)/" <SOURCE_DIR>/m4/attribute.m4 | ||
60 | CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> && | 59 | CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> && |
61 | <SOURCE_DIR>/configure ${xCONFIG} | 60 | <SOURCE_DIR>/configure ${xCONFIG} |
62 | --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local | 61 | --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local |
@@ -72,5 +71,5 @@ ExternalProject_Add(tinc | |||
72 | rm -r <BINARY_DIR> | 71 | rm -r <BINARY_DIR> |
73 | ) | 72 | ) |
74 | 73 | ||
75 | add_library(exec SHARED src/main/c/exec.c) | 74 | add_library(main SHARED src/main/c/main.c) |
76 | add_dependencies(exec tinc) | 75 | add_dependencies(main tinc) |