diff options
Diffstat (limited to 'app/build.gradle')
-rw-r--r-- | app/build.gradle | 18 |
1 files changed, 10 insertions, 8 deletions
diff --git a/app/build.gradle b/app/build.gradle index 33514ea..a707cbb 100644 --- a/app/build.gradle +++ b/app/build.gradle | |||
@@ -1,5 +1,6 @@ | |||
1 | apply plugin: 'com.android.application' | 1 | apply plugin: 'com.android.application' |
2 | apply plugin: 'me.tatarka.retrolambda' | 2 | apply plugin: 'kotlin-android' |
3 | apply plugin: 'kotlin-android-extensions' | ||
3 | 4 | ||
4 | android { | 5 | android { |
5 | compileSdkVersion 25 | 6 | compileSdkVersion 25 |
@@ -7,10 +8,12 @@ android { | |||
7 | defaultConfig { | 8 | defaultConfig { |
8 | applicationId "org.pacien.tincapp" | 9 | applicationId "org.pacien.tincapp" |
9 | minSdkVersion 21 | 10 | minSdkVersion 21 |
10 | targetSdkVersion 25 | 11 | targetSdkVersion 21 |
11 | versionCode 1 | 12 | versionCode 1 |
12 | versionName "0.1-preview" | 13 | versionName "0.1-preview" |
13 | testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" | 14 | ndk { |
15 | abiFilters 'x86', 'x86_64', 'armeabi', 'armeabi-v7a', 'arm64-v8a' | ||
16 | } | ||
14 | } | 17 | } |
15 | buildTypes { | 18 | buildTypes { |
16 | release { | 19 | release { |
@@ -18,10 +21,6 @@ android { | |||
18 | proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' | 21 | proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' |
19 | } | 22 | } |
20 | } | 23 | } |
21 | compileOptions { | ||
22 | sourceCompatibility JavaVersion.VERSION_1_8 | ||
23 | targetCompatibility JavaVersion.VERSION_1_8 | ||
24 | } | ||
25 | externalNativeBuild { | 24 | externalNativeBuild { |
26 | cmake { | 25 | cmake { |
27 | path "CMakeLists.txt" | 26 | path "CMakeLists.txt" |
@@ -45,5 +44,8 @@ dependencies { | |||
45 | exclude group: 'commons-logging', module: 'commons-logging' | 44 | exclude group: 'commons-logging', module: 'commons-logging' |
46 | } | 45 | } |
47 | 46 | ||
48 | compile 'com.annimon:stream:1.1.5' | 47 | compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" |
48 | } | ||
49 | repositories { | ||
50 | mavenCentral() | ||
49 | } | 51 | } |