aboutsummaryrefslogtreecommitdiff
path: root/lib/mk-sandbox-system.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mk-sandbox-system.nix')
-rw-r--r--lib/mk-sandbox-system.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/mk-sandbox-system.nix b/lib/mk-sandbox-system.nix
index 9408be3..68a13a7 100644
--- a/lib/mk-sandbox-system.nix
+++ b/lib/mk-sandbox-system.nix
@@ -11,7 +11,7 @@ let
11 shellLib = flake.lib.shell { inherit pkgs; }; 11 shellLib = flake.lib.shell { inherit pkgs; };
12 12
13 print = rec { 13 print = rec {
14 printSharedDir = name: { source, target }: '' 14 printSharedDir = name: { source, target, ... }: ''
15 echo -en ${shellLib.fmt.keyword target}": " 15 echo -en ${shellLib.fmt.keyword target}": "
16 echo ${pkgs.lib.escapeShellArg source} 16 echo ${pkgs.lib.escapeShellArg source}
17 ''; 17 '';
@@ -118,7 +118,7 @@ in rec {
118 118
119 apps.${name} = { 119 apps.${name} = {
120 type = "app"; 120 type = "app";
121 program = toString (pkgs.writeShellScript "sandbox-vm" ('' 121 program = pkgs.lib.getExe (pkgs.writeShellScriptBin "sandbox-vm" (''
122 # Save current directory for mounting in VM 122 # Save current directory for mounting in VM
123 SHARED_CWD=$PWD 123 SHARED_CWD=$PWD
124 export SHARED_CWD 124 export SHARED_CWD