summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorpacien2022-11-29 20:36:27 +0100
committerpacien2022-11-29 20:36:27 +0100
commitf1b105571b35b72f5f32c6e2e9c645580b17c0bc (patch)
treea21343a364fef24a8f48c842960367bb449be8d1 /flake.nix
parent60f95da08b900a8a2445cdd49069b607221b2ade (diff)
downloadmarkdown-course-website-f1b105571b35b72f5f32c6e2e9c645580b17c0bc.tar.gz
flake: add nix flake with tools
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..e465964
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,32 @@
1# Author: Pacien TRAN-GIRARD
2# Licence: EUPL-1.2
3
4{
5 inputs = {
6 # Not yet merged.
7 # quarto: 1.1.251 -> 1.2.269: https://github.com/NixOS/nixpkgs/pull/201551
8 nixpkgs.url = "github:NixOS/nixpkgs/a0297ff";
9 flake-utils.url = "github:numtide/flake-utils";
10 flaky-utils.url = "git+https://cgit.pacien.net/libs/flaky-utils";
11 };
12
13 outputs = { self, nixpkgs, flake-utils, flaky-utils }:
14 flake-utils.lib.eachDefaultSystem (system:
15 with nixpkgs.legacyPackages.${system};
16 let
17
18 tools = [
19 pandoc
20 quarto
21 ];
22
23 in lib.fold lib.recursiveUpdate { } [
24
25 {
26 devShell = flaky-utils.lib.mkDevShell {
27 inherit pkgs tools;
28 };
29 }
30
31 ]);
32}