aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index e09265f..578bb9b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,7 +4,9 @@
4 4
5{ 5{
6 inputs = { 6 inputs = {
7 nixpkgs.url = "github:NixOS/nixpkgs/nixos-21.05"; 7 # for python3Packages.embrace: https://github.com/NixOS/nixpkgs/pull/131425
8 nixpkgs.url = "github:pacien/nixpkgs/3faf31d";
9 #nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
8 flake-utils.url = "github:numtide/flake-utils"; 10 flake-utils.url = "github:numtide/flake-utils";
9 }; 11 };
10 12
@@ -13,8 +15,13 @@
13 with import nixpkgs { inherit system; }; 15 with import nixpkgs { inherit system; };
14 let 16 let
15 17
16 develPackagesAndScripts = [ 18 python = python39;
19
20 develPackagesAndScripts = with python.pkgs; [
17 postgresql_13 # PostgreSQL server with the standard admin tools. 21 postgresql_13 # PostgreSQL server with the standard admin tools.
22 ipython # Interactive Python REPL for experimenting.
23 psycopg2 # PostgreSQL driver for Python
24 embrace # bridges raw SQL queries to Python functions
18 25
19 # More pleasant alternative to psql, with colours and auto-completion. 26 # More pleasant alternative to psql, with colours and auto-completion.
20 # Custom configuration to suppress irrelevant warnings and messages. 27 # Custom configuration to suppress irrelevant warnings and messages.